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MODULE TWO: Excel Tools 
Module Two consists of 4 videos: 

1. Mixed Referencing and Named Ranges 
2. Conditional Formatting 
3. External File Links 
4. Protecting, Hiding and Grouping 

 

Log into your online course and download the Excel templates on each video page. Follow along with 
the video demonstration, and save your model.  Note that the Excel models in Module Two are not 
required uploads for this course, however, you are welcome to submit them if you’d like us to check 
that you’re on the right track.   
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Video 2.1: Mixed Referencing and Named 
Ranges 
Recommended Reading: See the section on “Cell Referencing Best Practices” in Chapter 5, Page 119 
as well as “Named Ranges” on Page 123 of Using Excel for Business Analysis. Below is an extract 
from this chapter: 
 

Mixed Cell Referencing  
One of the points of best practice in financial modelling is to have exactly the same formula all the 
way across and all the way down the block of data. In order to do that you need to understand where 
the dollar signs ($) go.  

 

Background: For example, let's say you are borrowing $250,000 at a rate of 7.5%, but want to see 
what interest you’d pay at different rates and different borrowing amounts. 

1. Open the file called “Mixed Referencing and Named Ranges” as shown in the video 
2. In cell B2, create a formula, using absolute referencing, that can be dragged across and down 

the entire block to cell D4 in one action (without editing), hence showing the interest payable 
for different borrowing amounts at different interest rates.  

http://www.plumsolutions.com.au/using-excel-business-analysis
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3. Remember that if you want to anchor the row, the dollar sign goes in front of the row, and to 
anchor the column, the dollar sign should be in front of the 
column.  

4. Try to do it using your keyboard shortcuts.  Use the arrow keys 
to navige, and toggle the F4 shortcut key to add and remove the 
$. Spend a few minutes on this before watching the video to see 
the answer.  

5. Your formula in cell B2 should look like this:  =$A2*B$1 
6. Copy your formula across and down the block of data so that it looks like this: 

 

 

Note that understanding mixed cell referencing is critical for good financial modelling practice and so 
it's important for a financial modeller to understand mixed cell referencing. The fewer unique 
formulas in your model the better! Formula consistency is fundamental to best practice for a 
number of reasons.   

Consistent formulas using mixed references are: 

- faster to build and more efficient  
- less prone to error 
- cheaper to audit 

 

Exercise: Creating a Capital Budget Schedule 
Background: We’ve just had our annual budget approved, and we need to create a schedule for the 
next 12 months.  Let’s practice using our relative cell references to build this capex schedule. 

1. Go to the Sheet called “Schedule” in the file called “Mixed Referencing and Named Ranges” 
as shown in the video 

2. Calculate the total budget in column E by writing the formula =D3*C3 into cell E3 and copying 
down the range as shown 

3. In cell G3 we need to test whether the date in row 2 is the same as the date in column F.  We 
can do this using an IF statement.  Write the formula =IF(G2=F3,E3,0). 

4. Insert the dollar signs by using the F4 shortcut.  Your formula should be =IF(G$2=$F3,$E3,0)  
5. Copy this formula across and down the table. 
6. Add your total in column S, and in row 17 by using the shortcut ALT= 

It's much better ergonomically if 
you can try to use your keyboard 
shortcuts as much as you possibly 
can instead of the mouse. 
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7. We know that the total cell S17 should be equal to the total in E17 and a good financial 
modeller is always looking for opportunities to put in error check, so in cell S18, add a very 
simple error check by writing formula =S17-E17. 

8. Change the formatting to comma style to remove the zero and CUT and paste (not copy and 
paste) the formula to cell E1. 

 
We can see that using mixed cell referencing, and using the F4 shortcut in particular, made building 
this model much quicker and easier than it would otherwise have been. 

 
Named Ranges 
Excel allows you to select a single cell, or a range of cells, and give it a name. You can then use the 
name to move to the cells and select them, or include them in a formula. 

Why Use a Named Range? 

Those new to named ranges sometimes struggle to see the benefits of including them in models. It's 
true that most of the time named ranges are not entirely necessary, but there are some good 
reasons to use named ranges when building a model: 

 

Creating a Named Range 

Background: We have used an absolute reference to anchor our formula to the consistent price of 
$450. 

9. Go to the Sheet called “Named” in the file called “Mixed Referencing and Named Ranges” as 
shown in the video 

10. Select cell B2 and look at the Name box in the top left-hand corner.  This cell is called B2, and 
this won't change; however, we can also change the name of it to something else. 
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11. Go to the Name box in the top left-hand corner and type over the name as shown in the video.  
Call it something else, like Price, and press Enter. Alternatively, you can select Define Name 
from the Defined Names group on the Formulas Tab, but typing over the cell reference in the 
name box is faster. 

 
Note that the name must not contain any spaces or special characters. For instance, if you want to 
call it Year 1 Price, you'd need to call it Year1Price or Year1_Price. 
Named ranges don't necessarily need to be confined to only a single cell; you can also create named 
ranged for an entire range of cells, and these can be used in formulas. Simply highlight the range 
instead of a single cell, and type over the name as shown above. 
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Video 2.2: Conditional Formatting 
Recommended Reading: See the section on “Conditional Formatting” in Chapter 7, page 193 of 
Using Excel for Business Analysis 

Exercise: Automatically Highlighting Large Variances in Reporting 

Background: We’d like to highlight any large variances so that they automatically change colour as 
the numbers change. 

Exercise:  

1. Open the file called “Conditional Formatting” as shown in the video. 
2. Select the first tab called “CF P&L” and highlight the range F6:F73 
3. Select the Conditional Formatting Icon on the Home Tab, Highlight Cells Rules and then 

Between 
4. Edit the fields to format the cells which fall between -30% and 30% as shown in the video, 

leave the default colour as Light Red Fill with Dark Red Text, and press OK 
5. This gives us the opposite of what we want to show, so we are going to edit this by going back 

into Conditional Formatting, select Manage Rules, select the rule that you have just created 
and select Edit Rule 

6. Change the rule so that instead of “between” it highlights the cells “not between” instead 
7. Test that your conditional formatting works by changing one of the values in the report, for 

example, go to cell C6 and change the value to $310,000 instead which is an acceptable 
amount, and we can see that the red conditional formatting will disappear 

 
Exercise: Graphically show Magnitude of Values on a Report Using 
Data Bars 

Background: We are trying to decide between showing data as a chart or as a table on our report, to 
give our numbers a little more meaning. 

Exercise:  

1. Go to the file “Conditional Formatting” and select the sheet called “Data Bars”, as shown in 
the video 

2. Highlight the range D4:D35 and select the Conditional Formatting Icon on the Home Tab 
3. Select Data Bars, and then choose the bar you’d like to show on the report 
4. Test your data bars by changing one of the values, for example, go to cell C4 and change the 

value from $400,000 to $40,000.  We can see that this changes the distribution of the data 
bars throughout the column. 

 
 

http://www.plumsolutions.com.au/using-excel-business-analysis
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Exercise: Adding Visual Interest using Colour Scales 

Background: Let’s jazz up an otherwise boring report using some basic conditional formatting and 
colour scales. 

Exercise:  

1. Go to the file “Conditional Formatting” and select the sheet called “Colour Scales”, as shown 
in the video 

2. Highlight the range B3:M7 and select the Conditional Formatting Icon on the Home Tab 
3. Select Color Scales, and then choose the colour scale you’d like to show on the report 
4. We can edit the colours shown by going back into Conditional Formatting, selecting Manage 

Rule, and then selecting the rule that you have just created and selecting Edit Rule.  Change 
the colours to your desired selection. 

 
Now let’s apply some informative colour to the next block of data below.  We cannot apply data 
bars, colour scales or icon sets to this data because it contains text instead of numbers, but we can 
still apply colour using standard conditional formatting. 

5. Highlight the range B10:M14 and select the Conditional Formatting Icon again.  Select 
Highlight Cells Rules and then Equal To. 

6. In the field type OK and change the colour in the drop-down box to green.  This will change all 
the cells with a value of “OK” to green. 

7. Let’s do the same thing for the next one. Create another rule for when the cells are equal to 
“Too Hot”, and select Light Red Fill with Dark Red Text (this step is not shown in the video). 

8. Now we will create the last rule for when the cells are equal to “Too Cold” and we’d like to 
change the colour to blue.  This colour does not exist in the pre-set options however, so we 
will need to select Custom Format… and manually select a blue background and font colour. 

9. Test your formatting now by changing either of the Min or Max Temp values, for example, 
change the Max Temp in cell P3 from 25 to 20 and watch the formulas and colours change. 

Using Conditional Formatting can quickly and easily provide a little more meaning to the outcome of 
our model. Automatically changing colours can really add an extra element of depth and meaning to 
your model. 
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Video 2.3: External File Links 
Recommended Reading: See the section on “Linking to External Files” in Chapter 4, page 83 of Using 
Excel for Business Analysis. Below is an extract from this chapter: 

Linking To External Files 

One of the important principles in Excel modelling best practice is to link to the source data. 
Wherever possible, hard coding should be avoided, and you should always try to link your cells so 
that as variables change, the results remain accurate. 

However, if your source data exists in an external file, this can cause many problems, such as broken 
links, incorrect data, and error messages. In fact, some analysts avoid linking to external files at all 
costs! However, if done properly, external links add value to your models. 

 

 
 

 

 

 

http://www.plumsolutions.com.au/using-excel-business-analysis
http://www.plumsolutions.com.au/using-excel-business-analysis
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The table below shows the problems and solutions as to why many analysts don't link to external 
files. 

 
 

Why You Should Use Named Ranges in External Links 

One of the main issues with linking to external files is that if users insert or delete rows or columns in 
the source file, this can easily mess up the files that are linking to it. 

Imagine you want to use a pricing threshold in your financial model, which is being generated in 
another model. Using best practices, you decide to create a link, rather than hard coding the 
number. This will make your model more auditable so that we can see exactly how that threshold 
amount was calculated. You create a link from your financial model to another source file, using the 
link:=‘C:\Plum Solutions\Clients\Transactions\Files\[Financial Statements.xlsx]July‘!$C$46 
If you are using Excel for Mac 2011, your file name might look more like this: 

=‘MacintoshHD:Users:plumsolutions:Dropbox:Clients:Transactions:Files:[Financial 
Statements.xls]July‘!$C$46 
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If both files are open at the same time, and you insert a row in 
the Financial Statements file, the link will automatically update 
from $C$46 to $C$47. However, if your file is closed, your model 
will not update. This means that next time you open it, your 
model will be picking up the wrong cell! 

The way around this issue is to create a named range in the 
source file (for example, threshold) and then if that cell moves 
in the source file, the cell will still retain its name, and the 
formula in your model will still be correct. See “Named Ranges” 
in Chapter 5 for how to do this. 

=‘C:\Plum Solutions\Clients\Transactions\Files\[Financial Statements.xlsx]July‘!threshold) 
The next time your model tries to update the link, it will look for the name threshold, rather than 
$C$46, and the integrity of the link will be maintained. This is why using named ranges when dealing 
with external links is considered best practice; it a much more robust way of linking files together. 

Dealing with Links and the Potential Errors They Can Cause 

If you have linked two files together, you should not start moving either of the files around into 
other drives or directories. If you do, Excel will not be able to find the file that has been moved, and 
the link will be broken. If a file has been moved or had a name change, you can try to amend this by 
using Edit Links as described in the following text. 

Before you start linking workbooks together you need to think about what will happen to the 
workbooks in the long term. Will other people be using them? Will they be making copies? Will they 
be mailing copies to other people? If so, then perhaps in that case, you should avoid creating a link 
to an external spreadsheet.  

How To Edit Links 

1. Click on Edit Links on the Data tab, 
in the Connections group.  

2. In Excel for Mac 2011, go to Edit, 
then select Links. 

3. Use the Change Source button to 
tell your model the new location of 
the file it has been linked to. 

Tip 
Another handy use for Edit Links is to break all links in a file. If you are e-mailing a file, it is not 
recommended that you leave links in it. You could paste the cell values one by one, but breaking links 
will convert every single formula in the entire file to their hard-coded values. Click on Edit Links, and 
then you will be able to select the external files and click on the Break Links button. See the image 
below: 
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Break Link Dialog Box 

 

Linking Do's and Don'ts 

Here are some common do's and don'ts to keep in mind when linking: 
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Video 2.4: Protecting, Hiding and Grouping 
Recommended Reading: See the section on “Bullet-Proofing your Model” in Chapter 7, page 204 of 
Using Excel for Business Analysis. Below is an extract from this chapter. 

If your model is publicly available, or if you have a lot of users entering data into it (especially if their 
Excel skills are questionable), it's a good idea to spend some time protecting it and making sure that 
all your hard work is not inadvertently corrupted! 

Methods of Model Protection 

Once you have completed building your model, there are three basic 
layers of protection you can include: 

1. Protect the file so that no one can open it without 
the password. 

2. Protect the structure of the workbook so that no 
structural changes can be made (normally used for 
hiding sheets and restricting access to them). 

3. Unlock individual cells on the worksheet and then 
protect the sheet so that only those cells that are 
unlocked can be changed. 

Protecting the structure or worksheets can be done with or without a 
password. Passwords are case-sensitive. 

 

Creating a Bullet-Proof Currency Calculator 

Background: We’d like to create a calculator that will automatically convert $AUD into regional 
currency based on the region we have selected. 

1. Open the “Protecting, Hiding and Grouping” file as shown and select the “Drop-down” sheet 
2. In cell A2, create a Data validation drop-down list based on the Locations in column G as 

shown 
3. Create a formula in cell B2 which will pick up the currency of whichever location has been 

selected in the drop-down list.  Your formula should be =VLOOKUP(A2,$G$2:$I$8,2,0) 
4. Copy the formula in cell A2 to cell D2 
5. Edit the formula so that it picks up the corresponding rate for the currency that has been 

selected.  Your formula in cell D2 should be =VLOOKUP(A2,$G$2:$I$8,3,0) 
6. Now divide the price by the currency exchange rate.  The formula in cell D2 should now be 

=C2/VLOOKUP(A2,$G$2:$I$8,3,0) 
7. Change your formatting, and test by changing the drop-down to see if the rates change 

 

 

Warning: Bear in mind, that 
passwords can be hacked 
reasonably easily. Note that there 
are programs out there that can 
decode a password.  (Try typing 
“Crack Excel password” into Google 
sometime.) If your file contains 
highly sensitive information, do not 
rely on passwords in Excel. Password 
protection is intended to be a 
deterrent, not a definitive solution. 

http://www.plumsolutions.com.au/using-excel-business-analysis


FINANCIAL MODELLING IN EXCEL (INTERMEDIATE) – MODULE 2 – EXCEL TOOLS 

 

© Plum Solutions Pty Ltd Page 16  www.plumsolutions.com.au 

 

Protecting, Hiding and Grouping on a Staffing Budget Model 

Background: We’re creating our departmental budget and we’d like to forecast how much our staff 
will cost us based on their start dates. 

1. In cell D3, calculate the staff costs with the formula =C3*B3  and copy it down 
2. In cell F3 we now need to calculate their costs using an IF statement.  Your formula should be 

=IF(F$2>$E3,$D3/12,0). Copy it across and down the block of data. 
3. Add your totals in column R and in row 7 

 

Now, the way we have built this, it will allow the user to enter any date in column E.  We don’t want 
this to happen because the way our formula works it will only calculate from the start of the month, 
so we need to restrict the user entry in column E. 

4. Change cells E3:E6 so that it will only allow the dates that have been entered into our 
schedule.  We can do this using a data validation drop-down box like the one shown below: 
 

 

 

5. Now I’d like to enter in a formula that will show when this budget was last updated.  In cell 
F1, enter the formula =TODAY(). 

6. We can stop people from entering a date in the future with a data validation as shown below: 
 

 

7. Test this by trying to enter a date way in the future 
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The next thing I’d like to do is to make this model a little more discreet by not showing the staff 
salaries.  It’s not very good practice to simply hide the columns; and it’s much better modelling 
practice to group the columns instead so that we can see that there are hidden columns. 

Alternatively, we could move the confidential data to another page. 

1. Remove any grouping you may have inserted, highlight columns C 
and D, and cut and paste these columns to columns B and C in 
the next sheet as shown 

2. Go back to the “Staff Budget” sheet, and delete columns C and D 
which are no longer being used 

3. We can now hide the “Salaries” by right-hand clicking on the tab, and selecting Hide 

4. To make it even more robust, protect the structure of the workbook by selecting Protect 
Workbook from the Review Tab on the Ribbon.  A password is optional. 

5. If you would like to protect the sheet itself, select the cells you would like to be changed 
(such as cells B3:C6 on the “Staff Budget” sheet), right-hand click, Format Cells and under 
the Protection tab, untick the Locked tick box. 

6. When you select Protect Sheet from the Review tab on the Ribbon, the entire sheet will be 
protected, with the exception of the cells which have been changed. 
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Be sure to CUT and 
paste, not copy and 
paste, as this way the 
formula links will follow 
 


